CVSS 3.1 Score 5.4 of 10 (medium)


Published Jul 18, 2023
Updated: Nov 7, 2023


CVE-2023-2433 is a vulnerability in the YARPP plugin for WordPress, affecting versions up to and including 5.30.3. It is classified as a Stored Cross-Site Scripting (XSS) vulnerability. The vulnerability occurs due to insufficient input sanitization and output escaping, allowing contributor-level attackers to inject arbitrary web scripts that will execute whenever a user accesses an injected page. The affected products include various versions of the YARPP plugin for WordPress. To remediate this vulnerability, users should update their YARPP plugin to a version beyond 5.30.3 or apply any available patches or fixes provided by the plugin developers. The potential danger posed to an organization is that attackers can exploit this vulnerability to execute malicious scripts on vulnerable websites, potentially leading to unauthorized access, data theft, or other malicious activities.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-2433 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options