CVE-2023-22524

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Dec 6, 2023
Updated: Dec 11, 2023
CWE ID 284

Summary

CVE-2023-22524 is a critical remote code execution vulnerability affecting certain versions of the Atlassian Companion App for MacOS. This vulnerability allows an attacker to bypass Atlassian Companion's blocklist and MacOS Gatekeeper using WebSockets, enabling the execution of malicious code. The vulnerability affects multiple products including tw7U8E, tw7U8F, tw7U8C, tw7U8D, tw7U8A, tw7U8B, tw7U72, tw7U73, tw7U70, tw7U71, eCJhF3, tw7U7-, tw7U7_, tw7U78, tw7U79, tw7U76, tw7U77, tw7U74, and tw7U75. The risk score is 79 out of 100 with a base severity of CRITICAL according to NVD@NIST. Organizations should update their Atlassian Companion App for MacOS to the latest version to remediate this vulnerability and mitigate the potential danger it poses for unauthorized code execution and compromise of confidentiality and integrity.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-22524 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options