CVE-2023-2082

CVSS 3.1 Score 5.4 of 10 (medium)

Details

Published Jul 14, 2023
Updated: Nov 7, 2023
CWE ID 79

Summary

CVE-2023-2082 is a vulnerability affecting the "Buy Me a Coffee – Button and Widget Plugin" for WordPress versions up to and including 3.6. The vulnerability is identified as Cross-Site Scripting (XSS) due to insufficient sanitization and escaping on the 'text value set via the bmc_post_reception action. This allows authenticated attackers with subscriber-level permissions or higher to inject arbitrary web scripts into pages, which will execute when accessed by victims. The vulnerability has a risk score of 27, a base severity of MEDIUM, and a base score of 5.4 according to NIST's National Vulnerability Database (NVD). It requires low privileges and user interaction, with a network-based attack vector. The potential impact is low in terms of integrity and confidentiality, with no availability impact. A CVSS vector string of CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N is associated with this vulnerability. Remediation steps are not provided in the given information.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-2082 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options