CVE-2023-20095

CVSS 3.1 Score 8.6 of 10 (high)

Details

Published Nov 1, 2023
Updated: Jan 25, 2024
CWE ID 772

Summary

CVE-2023-20095 is a vulnerability in the remote access VPN feature of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software. It could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to improper handling of HTTPS requests. An attacker can exploit this vulnerability by sending crafted HTTPS requests to the system. This could result in resource exhaustion and lead to a DoS condition. The vulnerability has a base severity rating of HIGH and an exploitability score of 3.9 out of 10. It affects multiple products within the Cisco ASA Software and Cisco FTD Software range, posing potential danger to organizations using these products. Remediation for this vulnerability involves applying the necessary software updates provided by Cisco.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-20095 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options