CVE-2023-0437

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Jan 12, 2024
Updated: Jan 24, 2024
CWE ID 835

Summary

CVE-2023-0437 is a cyber vulnerability that affects all versions of the MongoDB C Driver prior to 1.25.0. It is categorized as CWE-835, which refers to a loop with an unreachable exit condition. This vulnerability can cause an infinite loop when calling bson_utf8_validate on certain inputs. The potential danger this vulnerability poses to organizations is rated as high, with a base severity score of 7.5 out of 10 and an impact score of 3.6 out of 10. Remediating this vulnerability involves updating the MongoDB C Driver to version 1.25.0 or later.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-0437 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options