CVE-2022-4952

CVSS 3.1 Score 3.5 of 10 (low)

Details

Published Jul 17, 2023
Updated: May 17, 2024
CWE ID 400

Summary

CVE-2022-4952 is a vulnerability found in OmniSharp csharp-language-server-protocol up to version 0.19.6, affecting the JSON Serializer component's function CreateSerializerSettings in the file src/JsonRpc/Serialization/SerializerBase.cs. This vulnerability can lead to resource consumption. To remediate this issue, it is recommended to upgrade to version 0.19.7, which includes a patch identified as 7fd2219f194a9ef2a8901bb131c5fa12272305ce. The vulnerability has a CVE ID name of VDB-234238 and poses a potential danger to organizations using the affected component.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2022-4952 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options