CVE-2017-5638

CVSS 2.0 Score 10.0 of 10 (high)

Details

Published Mar 11, 2017
Updated: Nov 7, 2023
CWE ID 20

Summary

CVE-2017-5638 is a vulnerability in the Jakarta Multipart parser in Apache Struts 2 versions 2.3.x before 2.3.32 and 2.5.x before 2.5.10.1. This vulnerability allows remote attackers to execute arbitrary commands by exploiting incorrect exception handling and error-message generation during file-upload attempts, using a crafted Content-Type, Content-Disposition, or Content-Length HTTP header with a #cmd= string. The vulnerability has been exploited in the wild in March 2017 and poses a high danger to organizations as it allows unauthorized execution of commands on affected systems. To remediate this vulnerability, organizations should update their Apache Struts framework to versions 2.3.32 or 2.5.10.1 or apply any necessary security patches provided by Apache Struts developers

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2017-5638 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options