CVE-2024-40605

CVSS 3.1 Score 4.8 of 10 (medium)

Details

Published Jul 7, 2024
Updated: Jul 9, 2024
CWE ID 79

Summary

CVE-2024-40605 is a vulnerability found in the Foreground skin for MediaWiki through version 1.42.1. This vulnerability allows for stored cross-site scripting (XSS) attacks through MediaWiki:Sidebar top-level menu entries. The affected products include various versions of Xz2hf and lG8y6q. To remediate this vulnerability, users should update their MediaWiki software to version 1.42.2 or later, which includes a fix for this issue. The potential danger of this vulnerability lies in the ability for attackers to inject malicious code into web pages viewed by users, leading to unauthorized access or manipulation of sensitive information.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-40605 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions