CVE-2024-39936

CVSS 3.1 Score 5.9 of 10 (medium)

Details

Published Jul 4, 2024
Updated: Jul 8, 2024
CWE ID 367

Summary

CVE-2024-39936 is a vulnerability found in HTTP2 in Qt versions before 5.15.18, 6.x before 6.2.13, 6.3.x through 6.5.x before 6.5.7, and 6.6.x through 6.7.x before 6.7.3, affecting various products. This vulnerability allows for the execution of security decisions on an established connection to occur too early due to the encrypted() signal not being emitted and processed yet. The potential danger posed by this vulnerability is high confidentiality impact, with a medium base severity rating of 5.9 according to the National Vulnerability Database (NVD). No user interaction or privileges are required for exploitation, and the attack vector is through the network. It is recommended to update affected versions to the latest secure release to remediate this vulnerability and mitigate its potential impact on an organization's security posture.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-39936 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions