CVE-2024-39891

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Jul 2, 2024
Updated: Jul 3, 2024
CWE ID 203

Summary

CVE-2024-39891 is a vulnerability in the Twilio Authy API, affecting Authy Android versions prior to 25.1.0 and Authy iOS versions prior to 26.1.0. This vulnerability allowed unauthorized access to certain phone-number data through an unauthenticated endpoint, which was exploited in June 2024. The endpoint accepted requests containing phone numbers and provided information on whether each number was registered with Authy. It is important to note that no Authy accounts were compromised as a result of this vulnerability. To remediate the issue, users should update their Authy Android and iOS applications to versions 25.1.0 and 26.1.0 or higher, respectively. This vulnerability poses a medium risk with a base severity score of 5.3 out of 10, with low confidentiality impact and no integrity or availability impact according to the CVSS vector string analysis (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N).

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-39891 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions