CVE-2024-39840

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Jun 29, 2024
Updated: Jul 3, 2024
CWE ID 787

Summary

CVE-2024-39840 is a vulnerability found in Factorio versions before 1.1.101. It allows a crafted server to execute arbitrary code on clients by leveraging certain Lua base module functions to execute bytecode and generate fake objects. This vulnerability affects multiple products, including bZCJUJ, wwBTgB, wwBTgD, and wwBTgC, among others. To remediate this issue, users should update their Factorio software to version 1.1.101 or later. The potential danger of this vulnerability is high as it can lead to unauthorized code execution on client machines, potentially compromising the integrity and confidentiality of an organization's data and systems.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-39840 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions