CVE-2024-38460

CVSS 3.1 Score 4.9 of 10 (medium)

Details

Published Jun 16, 2024
Updated: Jun 17, 2024

Summary

CVE-2024-38460 is a cyber vulnerability that affects SonarQube versions before 10.4 and 9.9.4 LTA. It has a risk score of 30 and a base severity of MEDIUM. The encrypted values generated by the Settings Encryption feature in SonarQube can potentially be exposed in cleartext as part of the URL parameters in the logs, such as SonarQube Access Logs and Proxy Logs. This vulnerability does not require user interaction and can be exploited over the network. It has a high confidentiality impact, but no integrity or availability impact. To remediate this vulnerability, users should upgrade to version 10.4 or 9.9.4 LTA of SonarQube.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-38460 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions